[linux-lvm] Fedora Core 3 system with lvm2 won't boot

Dan Stromberg strombrg at dcs.nac.uci.edu
Mon Dec 13 17:05:23 UTC 2004

Copied from https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=142737

Description of problem:
System won't boot

Version-Release number of selected component (if applicable):

How reproducible:
Probably difficult, but easy on my machine.  :)

Steps to Reproduce:
1. Shut down FC3 without sync'ing disks
2. Try to boot
3. It doesn't.
Actual results:
System won't boot

Expected results:
System should boot.

Additional info:
I have an FC3 system, that was happy, but is now unhappy.  This may be
related to someone, who shall remain nameless, having shut off the power
on it without doing an orderly shutdown.  Then again, maybe it was
because of a "yum -y update", because I put off rebooting for a while
after that.

Anyway, now when it tries to boot, I see:

Red Hat nash version 4.1.18 starting
  Reading all physical volumes.  This may take a while...
  Found volume group "VolGroup00" using metadata type lvm2
  2 logical volume(s) in volume group "VolGroup00" now active

...and that's it.  I've left it there for over and hour, and it never
gets past that.

I booted off of an FC3 rescue cd, and found that I could mount the /boot
partition, but I cannot mount the / partition.  I ran various lvm
commands that identified two lvm volumes on the system.
fsck'ing /dev/hda2 (which is /) is getting me no where though - it just
says "invalid argument".

I tried firing up device mapper and udev in order to get
a /dev/VolGroup00 directory, but it just wouldn't do it - at least, not
with the things I tried.  I could mkdir the directory, but then "lvm
vgmknodes" would remove it.

What do I need to do to get past this?  There's stuff in the filesystem
I want quite a bit.  :-S

I tried all 3 FC3 kernels I have on the system, but none would come up,
getting stuck at that same point.

When I boot up into
the rescue CD and let it try to find my fedora install, it gets really
confused.  More specifically, it says:

Searching for Fedora Core installations...

        0%              install exited abnormally -- received signal 15
                                kernel panic - not syncing: Out of
memory and no killable processes

If I remove "quiet" and add "single" to my boot options, I get:

EXT3-fs: INFO: recovery required on readonly filesystem.
EXT3-fs: write access will be enabled during recovery.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: dm-0: orphan cleanup on readonly fs

...and there it hangs.

Also, I ran memtest86 on the box for a while (a little over an hour),
and found no errors.

More information about the linux-lvm mailing list