[linux-lvm] Can't mount after crash

Dan Stromberg strombrg at dcs.nac.uci.edu
Tue Dec 21 21:53:04 UTC 2004

On Tue, 2004-12-21 at 21:10 +0000, Alasdair G Kergon wrote:
> On Thu, Dec 16, 2004 at 10:49:24AM -0800, Dan Stromberg wrote:
> > ext3 users list, 
> But you tried to mount it as ext2?
> Is it meant to be ext2 or ext3?

It's ext3, but ext2 tools are supposed to often work on ext3 -
especially if you're applying them to a -copy- of your data.  :)

> > and don't seem to be getting satisfaction.
> Probably because you're not giving people all the information they need
> to help you; and maybe even some of the things you've tried have made
> the problem worse - I don't understand yet why you did the pvcreates,
> for example, and are you certain the lvm2 backup file you used was 
> completely up-to-date?  

I have my data back now. As a reminder, what I did was:

On FC3's rescue disk...

1) Do startup network interfaces
2) Don't try to automatically mount the filesystems - not even readonly
3) lvm vgchange --ignorelockingfailure -P -a y
4) fdisk -l, and guess which partition is which based on size: the small
one was /boot, and the large one was /
5) mkdir /mnt/boot
6) mount /dev/hda1 /mnt/boot
7) Look up the device node for the root filesystem
in /mnt/boot/grub/grub.conf
8) A first tentative step, to see if things are working: fsck -
n /dev/VolGroup00/LogVol00
9) Dive in: fsck -f -y /dev/VolGroup00/LogVol00
10) Wait a while...  Be patient.  Don't interrupt it
11) Reboot

> Have you a kept a complete log (i.e. shell history) of every command 
> you ran on the system while trying to recover things?

Nope, but all seems fine now.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <http://listman.redhat.com/archives/linux-lvm/attachments/20041221/9361c247/attachment.sig>

More information about the linux-lvm mailing list