[linux-lvm] Problems with booting after changing certain volumes

Frank Bagehorn fba at zurich.ibm.com
Fri Jan 16 02:58:02 UTC 2004

Recently I had problems on a SuSE SLES 8 install.
When I created two more logical volumes in the rootvg, the machine would 
hang during boot stating
        ERROR 2 - writing volume group backup file 
/etc/lvmtab.d/rootvg.tmp in vg_cfgbackup
        unable to do a backup of volume group "rootvg"
        removing volume group "rootvg" from /etc/lvmtab
I tried to increase the root file system from 512MB to 1GB but that didn't 
So I removed the two lvs (and assumed I run into a strange bug that allow 
not more than 7 lvs..)
Instead I increased one of the other lvs and put the data in those.
Now I rebooted again (first time since I increased the lv) and get the 
same error.

How much space is necessary to do the volume group backup ?
Shall I increase the rootlv even further (e.g. to 2GB) ?
Or is the problem more than just not enough space ?
The lv in question is about 60GB. I have another lv in a second volume 
group that is the same size.
(i.e. a copy of the same data is held on an external disk.) And that 
doesn't seem to make a problem.

Dr. Frank Bagehorn
IBM Zurich Research Lab.
Saeumerstr. 4
CH-8803 Rueschlikon 
SMTP: fba at zurich.ibm.com
Notes: Frank Bagehorn/Zurich/IBM at IBMCH
phone: ++41 (01) 724 83 23  fax: ++41 (01) 724 89 59

More information about the linux-lvm mailing list