[linux-lvm] lvcreate complains and fails

Anoop Rajendra arajendr at cse.uta.edu
Sun Jun 20 03:26:13 UTC 2004

On Sat, 2004-06-19 at 16:43, Alasdair G Kergon wrote:
> On Sat, Jun 19, 2004 at 04:23:52PM +0000, arajendr at cse.uta.edu wrote:
> > tells me dev mapper is in the kernel.
> > Yet when I run lvcreate it gives me an error saying no /dev/mapper/control.
> There's a script to create it correctly, though it sounds like you did 
> the right thing.
> > One other error it gives me is Incompatible libdevmapper 1.00.17-ioctl, and
> > kernel driver.
> What does 'lvm version' report?
lvm version gives me 2.00.16
Library version is 1.00.17-ioctl
And the dm_mod driver gives me 4.1.0. This last one is from the kernel
logs.. not from when I run lvm version. When I run lvm version it still
says /dev/mapper/control not found.

> Should be 3 versions: If it doesn't give the dm kernel driver version, 
> look in the kernel message log for it.
> Alasdair


More information about the linux-lvm mailing list