[linux-lvm] pvcreate Couldn't find device ...

Cisco cisco66 at gmx.de
Thu Jun 24 18:36:33 UTC 2004

Hi all,

since upgrading to LVM2 i have a big problem.

I'm running Debian and Kernel 2.6.7

After reading the whole web and all available man pages i decided to delete
my volume group and start from a clean basis.
I erased all config files and purged all packages (debian) and reinstalled
everything (exept lvm10)
(i _do_ have backups of my data :))

Now to the problem:

I have 3 IDE disks: /dev/hde, /dev/hdg and /dev/hdh

Before the upgrade to lvm2 i just took the whole unpartitioned disks as PV's
and made a VG0 out of them with 9 LV's

Now i wanted to do the same and did a "pvcreate /dev/hde"
The result was "/dev/hde: Couldn't find device"
The disk is accessible for the system, because i can work with fdisk or "dd"
it to /dev/null without any errors !

I tried all possible (vcfgrestore and tried to restore the uuid and so on)
but nothing helped.
So I decided to partition the disk with fdisk and created one single

Now "pvcreate /dev/hde1" worked fine so i did the same with /dev/hdg and

The problem now is that it worked on /dev/hdh1 but when i try to "pvcreate
/dev/hdg1" i again get the error above.

In the meantime I'm rather desperated...

Any idea would be greatly appreciated !



More information about the linux-lvm mailing list