[linux-lvm] dm failure while trying to activate damaged LV

Cheretakis Christos xalkina at yahoo.com
Wed Jun 30 21:42:30 UTC 2004

Here's my story in short. I had an LVM1 setup with
kernel 2.4, with 4 disks (actually 3 disks + 4
partitions on the 4th disk) making up a VG. On the
VG lived (and still live, I hope) 3 LV with
filesystems. My trouble starts when one of those
disks crashed!

I installed kernel 2.6.7, device mapper (1.0.18) and
LVM2 (2.0.18) tools to recover the filesystems (yes,
there was no backup newer than 6 months ago).

I managed to completely recover all filesystems that
are on the LVs not containing the bad disk using the
partial activation feature of LVM2, but I'm getting a
dm error ("ioctl cmd 9 failed") for the one on the
problematic disk, and it cannot be activated.

Based on previous postings both on this list and on
the dm list and various info on man-pages, I created
an ioerror "device" exactly the size of the failed
disk, linked to it from /dev/ioerror, but the LV still
fails to activate.

Following debug messages of LVM, what the code does is
about this:
1) it creates a "soft"-device that is a concatenation
of the original disks & partitions, and replaces the
failed disk with mappings to /dev/ioerror
2) there's not just one single mapping to /dev/ioerror
the size of the original disk, but rather lots of
each one with size 8192 sectors
3) tries to reload the mapping and then fails with
"ioctl cmd 9 failed"

I also tried to recreate a mapping file following what
the lvm code did, and replacing the chunk-mappings of
8192 sectors with one single mapping, but it fails
with the same error.

  Thanx in advance for any help,


Do you Yahoo!?
Yahoo! Mail - 50x more storage than other providers!

More information about the linux-lvm mailing list