[linux-lvm] Strange problems, is it the lvm?

Nikolay Dimitrov nIks at demonnet.org
Sat May 8 22:48:27 UTC 2004

I've created a 680gb volume group with reiserfs on top of lvm, which is 
used frequently by users. it worked fine for two weeks and now I have 
that strange problem:
root at main:~# ls /users
/usr/bin/ls: /users/Hell: Permission denied
/usr/bin/ls: /users/Blade: Permission denied
/usr/bin/ls: /users/Ferdy: Permission denied
Seems like a fs corruption to me. I fixed that with reiserfsck 
--rebuid-tree. The system worked fine again for a few days and the 
problem appeared again. My configuration is Slackware 9.1 updated to 
current, linux kernel 2.6.4.
  LVM version:     2.00.08 (2003-11-14)
  Library version: 1.00.07-ioctl (2003-11-21)
  Driver version:  4.0.0

IMHO the problem is in the lvm or the combination lvm + reiserfs? 
Perhaps my lvm version is old or i need some patches to the linux kernel?
Do you have any idea what is the problem here? Any suggestions?

P.S. Please apologize me if you find that post a bit offtopic but I'm 

More information about the linux-lvm mailing list