[linux-lvm] Re: lvextend error on XFS

Frank J. Buchholz frankb at ercwc.org
Tue Nov 23 02:10:14 UTC 2004

>"Frank J. Buchholz" <frankb ercwc org> writes:
>>> "Frank J. Buchholz" <frankb ercwc org> writes:
>>>> Hello,
>>>> I recently attempted to extend my logical volume.  First I added an
>>>> additional physical volume to an existing volume group.  This worked
>>>> fine.
>>>> vgextend Volume00 /dev/sba
>>>> lvextend -L+100G /dev/Volume00/LogVol00
>>>> However when it came time to run the lvextend command I received a
>>>> number of  device-mapper errors.  While I was trying to determine what
>>>> the errors were I noticed that the filesystem that sits on the logical
>>>> volume being extended was no longer available.  I attempted to umount
>>>> the filesystem however the command froze.  I then rebooted the system
>>>> without mounting the filesystem in question and manually mounted the
>>>> filesystem. XFS reported back that it could not locate the superblock.
>>> I have done lvextend followed by xfs_growfs many times without any
>>> problems.  Have you checked for hardware errors?
>> Unfortunately the timing is far too coincidental to be a hardware error.
>Since you had just added another disk, it may not be so coincidental
>after all.
>> Just after typing the following command and recieving the following error
>> lvm> lvextend -L+1G /dev/Volume00/LogVol00
>>   Extending logical volume LogVol00 to 2.93 TB
>>   device-mapper ioctl cmd 9 failed: Invalid argument
>>   Couldn't load device 'Volume00-LogVol00'.
>>   Problem reactivating LogVol00
>The last line would explain why the filesystem went offline.
>Something went wrong just after the LV had been extended, and was
>about to be reactivated.
>> I then noticed that the filesystem on LogVol00 was no longer available
>> and when I ran xfs_repair it stated the following:
>> # xfs_repair /dev/Volume00/LogVol00 
>> Phase 1 - find and verify superblock...
>> superblock read failed, offset 0, size 524288, ag 0, rval 0
>> fatal error -- Invalid argument
>What does "dmesg" have to say about this?
>I had a problem once with some strange errors from a disk.  It turned
>out the cable wasn't plugged in properly.
>Måns Rullgård
>mru inprovide com

Hello Måns
I now realize how I created this problem, I just don't know how to fix it.

I mistakingly added /dev/sba as the physical volume to a volume group 
that contained /dev/sba1, the one partition on sba.  These are 
essentially one in the same.  So when I executed the lvextend command 
device-mapper had an error.  I'm honestly surprised it did anything, 
especially write over the superblock on the filesystem.

Any direction on how I can recover from within LVM?  I never was able to 
execute the xfs_grow so I'm hoping the data in the filesystem still exists.


More information about the linux-lvm mailing list