[linux-lvm] re: Hello. About a bug in lvm2

Jord Tanner jord at indygecko.com
Thu Sep 23 17:22:10 UTC 2004

I had many problems with LVM2 on gentoo with the 2.6 kernel as well. My
solution was to first install the 2.6 kernel headers (linux26-headers),
recompile gcc, glibc, and glib, then install the latest unstable
versions of dev mapper and lvm tools (at that time it was
device-mapper-1.00.17 and lvm2-2.00.15). After that it worked
beautifully. As always YMMV.

(I should note that this was on a dual Opteron box, compiled in 64bit)

Jord Tanner

> Message: 5
> Date: Tue, 21 Sep 2004 17:46:55 +0200
> From: Sebastian Hyrwall <zibbe at cisko.org>
> Subject: [linux-lvm] Hello. About a bug in lvm2
> To: linux-lvm at redhat.com
> Message-ID: <41504CEF.8090508 at cisko.org>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> Hey.
> Im not sure but i may have found a bug in the lvm2 userspace-tools. Im
> using gentoo right now and right now
> lvm2 cant "see" some harddrives.
> I first discovered the problem when i changed from 2.4 -> 2.6. In 2.6
> it 
> didnt find all my discs. Later on i saw that when i did
> "pvcreate /dev/hdd1" (tried the devfs-link also /dev/ide/....) it 
> reported that the device couldnt be found.
> There isnt anything wrong with the hd or anything. It shows up in 
> cfdisk/fdisk and i can use it as a normal hd (not in an lvm).
> This occurs for 2 of my disks. hde and hdd. I cant find any difference
> between them and the other drives. They are all the same size.
> Unfortunently i cant provide any more information because i didnt
> think 
> about mailing this to you until after i went back to 2.4.
> Sincerely, Sebastian Hyrwall

Jord Tanner <jord at indygecko.com>

More information about the linux-lvm mailing list