[linux-lvm] Linux LVM - half baked?

Robin Green greenrd at greenrd.org
Thu Oct 13 11:18:34 UTC 2005

On Thursday 13 October 2005 01:30, Jed Donnelley wrote:
> Redhat LVM users,
> Since I mentioned a minor bug in Redhat/LVM (9/28 LVM(2) bug in RH ES
> 4.1 /etc/rc.d/sysinit.rc, RAID-1+0) I've done quite a number of
> additional installs using LVM.  I've now had my second system that
> got into an essentially unrecoverable state.  That's enough for me
> and LVM.  I very much like the facilities that LVM provides, but if I
> am going to lose production file systems with it - well, I will have to
> wait.
> Below are descriptions of the two problems I've run into.  I have run
> linux rescue from a CD for both systems.  The difficulty of course is
> that since the problem seems to be in the LVM layer, there are no
> file systems to work on (e.g. with fsck).

There should be. If the rescue CD supports LVM (like e.g. Fedora Core 4 CD 1)
then the LVM layer should at least be brought up, I would have thought. Did
you run fsck /dev/VolGroup00/LogVolxx after choosing to have the filesystems 
auto-mounted? If so, what happened when you tried that?

> In the other system (an x86 system) I had a disk failure in a software
> RAID-1 file system for the system file system (/boot /).  I replaced the
> disk and resynced it apparently successfully.  However, after
> a short time that replacement disk apparently failed (wouldn't
> spin up on boot).  I removed the second disk and restarted
> the system.  Here is how that went:
> ...
> Your System appears to have shut down uncleanly
> fsck.ext3 -a /dev/VolGroup00/LogVol02 contains a file system with
> errors, check forced
> /dev/VolGroup00/LogVol02 Inodes that were part of a corrupted orphan
> linked list found.
> (i.e. without -a or -p options)
> *** An error occurred during the file system check.
> *** Dropping you to a shell;  The system will reboot when you leave the
> shell.
> Give root password for maintenance (or type Control-D to continue)
> ---------------------
> All stuff very familiar to those who've worked on corrupted file
> systems.  However, in this
> case if I type Control-D or enter the root password the system goes
> through a sequence
> like:
> unmounting ...
> automatic reboot
> and reboots.  This starts the problem all over again.

Did you file a bug about this? It's rather hard to fix bugs if people don't 
file reproducable test cases in the relevant bug database.


More information about the linux-lvm mailing list