[linux-lvm] Problem with lvm2 and softwareraid

Johannes Ullmann j.ullmann at evva.com
Fri Oct 28 14:12:01 UTC 2005


I'm building a backup to disk system and i have strange problem with lvm
on top of 2 software raid 5 devices.
Each SW Raid-5 has 7x400GB HDDs (=2,4TB). On top of these two SW Raid
devices I created one big LV with 4,8TB.
I use Reiserfs as filesystem. I worked fine while the disk usage was
below 1,5TB, above that, the Filesystem was destroyed. I tried the same
with ext3 and had the same results.  So I't not the Filesystem. I also
checked the Softwareraid and the LV for any Problems but i haven't found
After reading many Mails/howtos/man-pages I quess that LVM can't handle
PV's which are larger than 2TB is this correct?
I haven't found anything in the documentation about the maximum PV size.

thanks for any help.

My setup looks like this:
Debian testing 2.6.12-1-686-smp
lvm2  2.01.04-5
mdadm  1.12.0-1

14x400GB SATA Hdds on two 3-Ware controllers.
mdadm --create /dev/md0 --chunk=64 --level=raid5 --raid-devices=7
mdadm --create /dev/md1 --chunk=64 --level=raid5 --raid-devices=7

pvcreate /dev/md0 (Softwareraid controller1)
pvcreate /dev/md1 (Softwareraid controller2)
vgcreate vg0 --physicalextentsize 16M /dev/md0 /dev/md1
lvcreate --stripes 2 --stripesize 64 -l <extends> --name backup vg0

I get this Filesystem errors:
Oct 21 15:30:02 backup1 kernel: ReiserFS: warning: is_tree_node: node
level 42225 does not match to the expected one 2
Oct 21 15:30:02 backup1 kernel: ReiserFS: dm-0: warning: vs-5150:
search_by_key: invalid format found in block 73668. Fsck?
Oct 21 15:30:02 backup1 kernel: ReiserFS: dm-0: warning: zam-7001: io
error in reiserfs_find_entry

Johannes Ullmann

EVVA-Werk Gesellschaft m.b.H. & Co. KG
Wienerbergstraße 59-65
A-1120 Wien
Tel.: +43-1-811 65 / 505
Fax: +43-1-811 65 / 16
e-mail: j.ullmann at evva.com
homepage: http://www.evva.com

More information about the linux-lvm mailing list