[linux-lvm] Problem with lvm2 and softwareraid

Zac Slade krakrjak at volumehost.com
Fri Oct 28 17:34:55 UTC 2005

Quoting Johannes Ullmann <j.ullmann at evva.com>:

> Hello!
> I'm building a backup to disk system and i have strange problem with lvm 
> on top of 2 software raid 5 devices.
> Each SW Raid-5 has 7x400GB HDDs (=2,4TB). On top of these two SW Raid 
> devices I created one big LV with 4,8TB.
> I use Reiserfs as filesystem. I worked fine while the disk usage was 
> below 1,5TB, above that, the Filesystem was destroyed. I tried the same 
> with ext3 and had the same results.  So I't not the Filesystem. I also 
> checked the Softwareraid and the LV for any Problems but i haven't found 
> anything.
> After reading many Mails/howtos/man-pages I quess that LVM can't handle 
> PV's which are larger than 2TB is this correct?
> I haven't found anything in the documentation about the maximum PV size.

Yes and No.  There was a max pv size.  If you use metadata format for version 1
it has a hard limit of 2 TiB for a pv size.  Using metadata format version 2 it
is an unsigned long int so the max pv size is 4 exabytes in length.  If you feel
that the pv size is holding you back you can force metadata version 2 when you
execute pvcreate (e.g. pvcreate -M1 for metadata version 1 or pvcreate -M2 for
metadata version 2).
> thanks for any help.

I hope that helps.  I can't imagine it actually being in reiser so I'd try
recreating the pvs.

Zac Slade
krakrjak at volumehost.com

This mail sent through IMP: http://horde.org/imp/

More information about the linux-lvm mailing list