[linux-lvm] pvmove is stuck

Martin Ebourne lists at ebourne.me.uk
Thu Sep 1 12:56:13 UTC 2005

On Thu, 2005-09-01 at 13:35 +0100, Alasdair G Kergon wrote:
> On Wed, Aug 31, 2005 at 11:50:05PM +0100, Martin Ebourne wrote:
> > But is there any other possible explanation than a bad sector? Only
> > there's several reasons I don't think there are any bad sectors:
> Well check for yourself if the mirroring process has worked:
> read the data from each side of the mirror and check it's
> identical.

Ah, should have thought of that. Doh.

>   If a small part of it isn't, try copying that
> part manually and see if it gives any errors.

What I did do (after still not finding any disk errors) was pvmove
--abort, then I restarted again. This time it copied the remaining two
parts entirely successfully.

I've no idea how the mirroring/kcopy is implemented. Does it retry if a
read fails? I was wondering if the self test initiated on the drive
could have caused a read to fail (though I'm sure it shouldn't).



More information about the linux-lvm mailing list