[linux-lvm] volume group uuid not found

Moshe Kaminsky kaminsky at math.huji.ac.il
Sat Apr 22 12:59:54 UTC 2006


I have the following problem: when running

vgchange -a y vg

I get errors of the following type:

Volume group uuid not found: ...

The ... stands for the concatenation of the VG uuid and the LV uuid for 
that volume (this is repeated for each logical volume.) The result is 
that the group is not activated. This happens also with a new test VG 
and LV I created, and for any operation with the LV (though sometimes 
the operation succeeds despite the message, eg when creating a new LV.)

Here are some other diagnostics that may be relevant:
When I run pvs I get the message

Can't read vg: skipping

When I run

lvdisplay -v /dev/vg/home

I get (among other things)

LV status: NOT available

I tried running 'vgcfgbackup' and 'vgcfgrestore', it didn't help.

The whole thing used to work, so this may be a result of some upgrade. 
This is all happening on a Gentoo system, with kernel version 2.6.16. 
The output of lvm version is:

LVM version: 2.02.03
Library version: 1.02.03
Driver version: 4.5.0

I can't try too many things there since almost all partitions on the 
machine are managed by lvm.

Any help is greatly appreciated,

I love deadlines. I like the whooshing sound they make as they fly by. 
                                        -- Douglas Adams
    Moshe Kaminsky <kaminsky at math.huji.ac.il>
    Home: 08-9456841

More information about the linux-lvm mailing list