[linux-lvm] New disk; "Couldn't find uuid" after successful pvcreate&vgextend

Barnaby Claydon bclaydon at volved.com
Sun Mar 5 13:51:57 UTC 2006

Hi all,

I've been successfully running LVM2 (2.01.04) on Debian Sarge 
(2.6.8-2-686) for months.

As I've done many times before, I added a new disk yesterday. I 
successfully ran the following, both without error:

pvcreate -v /dev/hdc
vgextend -v mono_media /dev/hdc

As standard practice to make sure everything was ok, I then ran:

vgscan -v

At this point I got several references to "Couldn't find uuid..." 
repeated with the same uuid several times. At this point it seemed 
logical to back-out my changes, so I tried to run the following:

vgreduce -v mono_media /dev/hdc

Unfortunately this gave the same "Couldn't find uuid..." errors as 
'vgscan'. As it seemed somewhat logical, I tried running the same 
'pvcreate' command, again without error:

pvcreate -v /dev/hdc

After 'pvcreate' had finished, I was THEN able to run 'vgreduce' and 
restore my 'mono_media' VG to working order.

At this point I was a bit baffled, running 'lvmdiskscan' after the 
initial 'pvcreate' shows the disk as present, but if I reboot after just 
that first 'pvcreate' step and run 'lvmdisksacn' after the reboot, 
/dev/hdc isn't shown.

To rule-out a hardware problem I successfully ran 'mkfs.ext3 /dev/hdc' 
and was able to mount and navigate the volume without errors. Last night 
I also left 'badblocks -svw /dev/hdc' running which is almost complete 
and hasn't found any errors yet.

I will reply with full command output once 'badblocks' has finished, but 
I hope this brief synopsis makes sense.

Thanks everyone!

More information about the linux-lvm mailing list