[linux-lvm] pvmove didn't work - now system won't boot

Chad Rebuck chadrebuck at gmail.com
Thu Mar 9 17:36:48 UTC 2006


Seems like some commands like the --ignorelockingfailure and some don't

pvscan shows /dev/hdc2 as [2g / 2g free]

and it my other drive now has 2g less free space so do I assume the
transfer of data worked correctly?

Now I need to run vgreduce I suppose to remove that drive from the
group.  However, the ignorelockingfailure option doesn't work.  Do I
just boot from a recovery cd and delete the lock file in /var/log/lvm
to proceed?


On 3/9/06, Luca Berra <bluca at comedia.it> wrote:
> On Thu, Mar 09, 2006 at 10:29:41AM -0500, Chad Rebuck wrote:
> >I ran "pvmove -v /dev/hdc2" to move the data off the drive but it
> >stopped before any real drive activity happened.  The system was stuck
> >for about 30 minutes not doing anything so I powered off/on.  Now it
> >boots into a bash prompt but suggests I run fsck manually.  I noticed
> >that lvm only reported that 2 of the 3 physical volumes were found.  I
> >can't run any lvm commands from here as I get a 'Locking type 1
> >initialization failed'.
> >
> run lvm commands with --ignorelockingfailure option
> >What steps do I take to get the system to boot again?  The root dir is
> >part of the lvm volume.  The /boot is separate from the lvm volume but
> >maybe this is required anyway for lvm to work.
> >
> >Thanks,
> >Chad
> >
> >_______________________________________________
> >linux-lvm mailing list
> >linux-lvm at redhat.com
> >https://www.redhat.com/mailman/listinfo/linux-lvm
> >read the LVM HOW-TO at http://tldp.org/HOWTO/LVM-HOWTO/
> --
> Luca Berra -- bluca at comedia.it
>        Communication Media & Services S.r.l.
>  /"\
>  / \
> _______________________________________________
> linux-lvm mailing list
> linux-lvm at redhat.com
> https://www.redhat.com/mailman/listinfo/linux-lvm
> read the LVM HOW-TO at http://tldp.org/HOWTO/LVM-HOWTO/

More information about the linux-lvm mailing list