[linux-lvm] Crash during root file system check on boot

Stephane Branchoux stephane.branchoux at univ-perp.fr
Mon Mar 27 19:57:50 UTC 2006


I run Redhats AS4.0 (2.6.9-34.ELsmp) with lvm2 .

My system crashes during file system check on boot :

/dev/VolGroup00/Logvol00 is mounted e2fsck : cannot continue, aborting.
give root password for maintenance.
I ran :

e2fsck -y /dev/VolGroup00/Logvol00  

Then, if i use vgchange -a y, and init 3, i cant mount all filesystems 
and all seems OK.

I tried to boot on cdrom in rescue mode in order to check root file 
system but i have same message.
This file system check occurs running /etc/rc.d/rc.sysinit script.

grub.conf is like this :
title Red Hat Enterprise Linux AS (2.6.9-34.ELsmp)
       root (hd0,0)
       kernel /vmlinuz-2.6.9-34.ELsmp ro root=/dev/VolGroup00/LogVol00 
rhgb  acpi=off vga=0x317
       initrd /initrd-2.6.9-34.ELsmp.img

How can i solve this problem ?

Many thanks in advance

stephane BRANCHOUX
Centre de Ressources Informatiques de l'Université de Perpignan.
mailto:stephane.branchoux at univ-perp.fr
04 68 66 21 24
Validation signature / Trusting signature: http://igc.cru.fr/trust.html

Ce message a ete verifie par MailScanner
pour des virus ou des polluriels et rien de
suspect n'a ete trouve.
CRI Université de Perpignan

More information about the linux-lvm mailing list