[linux-lvm] [BUG] Spaces in LVM1 LV names => *deep trouble* when converting to LVM2

Dominique Quatravaux dom at idealx.com
Thu May 11 07:55:03 UTC 2006

Hash: SHA1

Alasdair G Kergon wrote:

> I should add that what you should do is extract the metadata you've
> retrieved off disk directly into a file, fix it in the file
> (differences in whitespace & comments don't matter) then use
> vgcfgrestore -f.

I tried that and it works - strange, I tried vgcfgrestore yesterday to
no avail... But then I was using Ubuntu 5.10's lvm2 package as a
rescue so apparently it's a different (and solved) issue. Thanks!

Knowing this, and still for the record: after any LVM operation it
seems wise to try a vgchange -a y *before* rebooting to see if
everything went well. Reverting a pickled LVM situation is much easier
with the original toolset handy (same LVM binary and metadata backups
in /etc/lvm/) than using a rescue CD!

I wrote, and you replied:

>> * there should be a mechanism for dealing with corrupt LVM
>> metadata, at the minimum a global command-line switch to
>> temporarily disable checksum verifications.
> Nope.

I seem to have pushed your button, apologies for doing so. I was
trying to be humorous, not disparaging: *of course* I concur that
checksums are a good idea! I guess it means that humor is too slippery
for us non-native speakers, oh well...

- --
Dominique QUATRAVAUX                           Ingénieur senior
01 44 42 00 08                                 IDEALX

Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org


More information about the linux-lvm mailing list