[linux-lvm] LVM: pvcreate fails with: Cant' open exclusively

Egbert van.der Zande egbert.van.der.zande at oracle.com
Fri May 12 11:40:04 UTC 2006

Hi experts,

I have a Linux system that has 4 x 300G disks (dev/hd[efgh]). All four 
have a 20G raw device on partition 1 that is used by Oracle ASM. I 
wanted to assign the remaining diskspace to a logical volume. This was 
successful for /dev/hd[efg]2 but on /dev/hdh2 I get:

pvcreate /dev/hdh2
"Cant' open exclusively, Mounted filesystem?"

I'm in single user mode, as far as I can see /dev/hdh2 is not mounted 
(service rawdevices stop; so /dev/hdh1 is not used either)
fuser /dev/hdh2 does not reveal anything

Tried pvcreate --debug /dev/hdh2 but no additional info is given. I 
first thought it was the ASM / LVM combination but the other 3 disks 
work fine.

Then I removed all partitions and tried to do a
pvcreate /dev/hdh, same error (did a dd if=/dev/zero of=/dev/hdh bs=512 
count=1 to wipe out)
Also wiped out the entire disk.

Finally I created a partition and did a mkfs -ext3 /dev/hdh1, works fine

But LVM simply refuses!?

Any thoughts? Is there a way to get debug info?

LVM 2.02.01, driver 4.5.0
Redhat EL AS V4 U3 2.6.9-34 EL

More information about the linux-lvm mailing list