[linux-lvm] LVM2 tools<-->library<-->driver compatibility

Joe Harvell jharvell at dogpad.net
Tue May 16 22:27:55 UTC 2006

The problem is solved by upgrading the the device mapper library to 
1.02.05.  Thanks.

As for the 2.4 kernel, I have to use 2.4 on this box for Rational 
Clearcase MVFS compatibility.

Alasdair G Kergon wrote:
> On Tue, May 16, 2006 at 01:46:59PM -0500, Joe Harvell wrote:
>> How can I determine which combinations should be compatible?  What 
>> version of the tools/library do I need to downgrade to in my installed 
>> environment?  
> Don't downgrade userspace tools - upgrade them.  Best to use the same versions
> of userspace packages in both environments.  But avoid snapshots.
> (You'd need old packages on 2.4 to use them, and they're buggy anyway.)
> The 2.4 kernel patches haven't been updated for some time and contain some 
> bugs that already got fixed in the 2.6 tree.
> Alasdair

More information about the linux-lvm mailing list