[linux-lvm] lvcreate gives 'device-mapper: reload ioctl failed: Invalid argument'

Matt McHenry jerith at speakeasy.org
Tue Nov 14 18:43:07 UTC 2006

On Tue, 14 Nov 2006, Alasdair G Kergon wrote:

> On Sat, Oct 28, 2006 at 05:26:55PM -0400, Matt McHenry wrote:
> > thought that maybe one of my pvs was bad, so I tried to add a new pv
> > (sda12) and migrate off of the most-recently-added one (sda11), but the
> Could you have created the new one by subtracting space from the old one?
> You need to undo that change to the partition table.

	It's possible that I may have screwed up and thought that sda11
wasn't yet under LVM, deleted it, and then created a new sda11 and sda12
in its place (each taking half the space originally occupied by sda11).
But it was a while ago so unfortunately I don't remember for sure.

	So how can I repair this? I see two options:

1) remove the unused sda12 pv; remove the sda12 partition; delete and
re-create the sda11 partition to take up the space formerly occupied by
the sda12 partition

2) use pvmove to move all data off of the sda11 pv; remove the sda11 pv;
create a new pv on the sda11 partition, which should pick up the correct

	(2) seems better to me, except that I already tried the pvmove and
it and was getting the same 'reload ioctl' errors.  For (1), it seems like
there's more risk of data loss, and I'd need some way to figure out
exactly how big to make the new sda11 partition.  What do you think?  Is
there a third option I'm not seeing?

Matt McHenry
jerith at speakeasy.org
be052 at scn.org

More information about the linux-lvm mailing list