[linux-lvm] Contents of read-only LVM snapshot change when bothLV and SNAP are Read-Only - SOLVED

Roger Lucas roger at planbit.co.uk
Fri Nov 17 14:34:35 UTC 2006

Hi All,

The problem was nothing to do with LVM but was a RAID error.  I moved the two disks in the RAID-1 array between three different
machines - two were identical and one was a totally different motherboard.  The problem occurred on all of the machines so I tried
removing one of the disks and brought the array up in degraded mode.  When I re-ran the test, I consistently received the first data
sequence.  I powered off the machine and swapped the disks.  I then powered the machine up so that it was running off the other
disk, again in degraded mode.  When I re-ran the test, I consistently received the other data sequence.

What it looks like is happening is that, at some point in time, a write to the RAID array failed and wrote slightly different data
to one of the disks or one of the disks generated a bit error.  Since I was running in RAID-1 and the disks were not failing with a
hardware error, the MD driver seemed happy to return data from whichever disk completed the read first.  Since the disks were
identical, it was pretty random which one would get the data back first, hence the apparent inconsistency.

I don't know why it seemed that the main disk was stable but the snapshot wasn't, but I suspect that this is again down to the race
condition or some caching somewhere.

Thank you to everyone in the LVM team who has helped investigate this for me - I apologise for wasting your time with a false goose



More information about the linux-lvm mailing list