[linux-lvm] Rmove a faulty hard drive off LVM Group

mghofran at caregroup.harvard.edu mghofran at caregroup.harvard.edu
Fri Nov 17 20:45:52 UTC 2006

You are confusing the 11% free with the "Free PE". They are not the same
thing. The 11% is showing you "used / allocated" in your logical volume.
Another words "15281032 / 151527604 = 11% " however the free PE which is
160 MB, is the total unallocated space in the free bank of the volume
group. You could use that to extend the existing one (151527604) or
create a new one.


Hope that helped



From: linux-lvm-bounces at redhat.com [mailto:linux-lvm-bounces at redhat.com]
On Behalf Of Joann Deng
Sent: Thursday, November 16, 2006 8:10 PM
To: linux-lvm at redhat.com
Subject: [linux-lvm] Rmove a faulty hard drive off LVM Group





My system is a Sun Fire X 2100 with RHEL 4.0. It has two 80G ATA SCSI
disks. Right now, one of them is failing, and I need to remove it off
the LVM Group.


Here is the LVM layout:

# df -k

Filesystem           1K-blocks      Used Available Use% Mounted on

/dev/mapper/VolGroup00-LogVol00                      151527604  15281032
128549372  11% /

/dev/sda1               101086     18896     76971  20% /boot

none                   1036912         0   1036912   0% /dev/shm


But when I run vgdisplay, the system only have 160MB Free PE.


# vgdisplay

  --- Volume group ---

  VG Name               VolGroup00

  System ID

  Format                lvm2

  Metadata Areas        2

  Metadata Sequence No  3

  VG Access             read/write

  VG Status             resizable

  MAX LV                0

  Cur LV                2

  Open LV               2

  Max PV                0

  Cur PV                2

  Act PV                2

  VG Size               148.91 GB

  PE Size               32.00 MB

  Total PE              4765

  Alloc PE / Size       4760 / 148.75 GB

  Free  PE / Size       5 / 160.00 MB

  VG UUID               P7GrJk-v55z-YHlz-xPYL-v0eJ-jL6V-Cdo5OO


As the usage is only 11% for VolGroup00-LogVol00 as shown by "df -k", I
don't know why I only have 160MB PE free. 

I tried "pvmove /dev/sdb1", got the error message "insufficient suitable
contiguous allocatable  extents for logical volume pvmove 0:2384 more
required, unable to allocate temporary LV for pvmove".

Can someone please help me out?


Thanks a lot in advance,




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/linux-lvm/attachments/20061117/9832b995/attachment.htm>

More information about the linux-lvm mailing list