[linux-lvm] my PV's disappearing

Richard Mollel unixtipz at yahoo.com
Tue Nov 21 13:53:19 UTC 2006

--- Luca Berra <bluca at comedia.it> wrote:

> On Tue, Nov 14, 2006 at 09:56:22AM -0800, Richard
> Mollel wrote:
> >
> >Just before i sent this out...i saw this thread::
> >
> >And that was exactly my problem!! Not sure why!!
> >I have now been able to perform::
> >losetup /dev/loop0 /dev/sdb
> >losetup /dev/loop1 /dev/sdc
> >losetup /dev/loop2 /dev/sdd
> >
> can you please clarify if you are really using whole
> disks or did you by
> chance partition the devices.
> the message you cite was the fix for someone that
> did partition the disk
> after creating the PVs and filling LVM with data.
> if the device holds a partition table lvm commands
> will ignore the
> whole disk and try to find an LVM label on the
> partition.
> the loosetup trick will fool lvm tools (loop device
> are not
> partitionable)

Hi Luca,
It created these LVM volumes several years back on
LVM1...and to admit, were my first LVM's experience
then. So, i followed religiously the instructions,
whereby i had to create a partition, label it type
"8e" (LVM) on the partition. For some reason, back
then, i then performed pvcreate on whole device
(/dev/sdb, sdc,sdd) and not their partition. It all
worked OK for years, even after OS upgrade from
Mandrake 10.0 to Mandriva 2006.0, thus changing LVM to
LVM2. Until i ran s fresh pvscan was when i broke the
configuration. It seems to have been working on cache
(/etc/lvm/.cache) configuration, and a pvscan forced a
flush of that.
> >and, performed : vgchange -a y
> >(it complained of duplicate uuid's, recreated on
> >sdb1,sdc1 and sdd1 since pvcreate was complaining
> of
> >/dev/sdb,sdc & sdd not found!)
> pvcreate? did you pvcreate? on the partition?
> >I have been able to mount my reiserfs, so i can
> >continue with migration.
> >Issue which i have to take up with Mandriva guys is
> >why the failure all of a sudden? and do i need to
> be
> >performing losetup everytime? My original
> >configuration had used whole disks...
> >
> i did not see anything related to that on mandriva
> bugzilla, but in any
> case if the issue is that the whole device was
> partitioned after lvm
> creation there is not much i can do about it.
The whole device was partitioned before LVM
> L.
> -- 
> Luca Berra -- bluca at comedia.it
>         Communication Media & Services S.r.l.
>  /"\
>  / \
> _______________________________________________
> linux-lvm mailing list
> linux-lvm at redhat.com
> https://www.redhat.com/mailman/listinfo/linux-lvm
> read the LVM HOW-TO at
> http://tldp.org/HOWTO/LVM-HOWTO/

Sponsored Link

Compare mortgage rates for today. 
Get up to 5 free quotes. www2.nextag.com

More information about the linux-lvm mailing list