[linux-lvm] Restore after lvmove crash

Fabien Shum-King fabsk at free.fr
Tue Sep 5 19:30:29 UTC 2006


I'm sorry that this message doesn't appear in the existing thread, but I
received the mails in digest mode.

Summary: I used "pvmove /dev/sda2 /dev/sda7", the system crashed and I
get a invalid "pvmove0" LV I could not remove and prevented most actions
on the VG (including destroying the VG!).
"pvmove --abord" did not work (I searched a lot before asking here).

In fact, LVM was still scanning /dev/sda7 even if it was not used as a
physical volume and if I change the type of partition.
I don't know exactly which of these two actions solved the problem
(maybe both), but it did it:
- I removed the unused partition /dev/sda7 (and filled the free space
with /dev/zero so I don't get any problem in the future)
- I restored the metadata under another VG name (so my existing physical
volumes did not appear under the old corrupted VG), and I remove
everything. Then I restored the metadata onder the previous VG name. And
it worked

I hope that it could help someone in the future.


More information about the linux-lvm mailing list