[linux-lvm] Cannot get rid of root filesystem LVM snapshot

Nix nix at esperi.org.uk
Sun Sep 10 17:35:00 UTC 2006

On Sun, 10 Sep 2006, Alasdair G. Kergon gibbered uncontrollably:
> Upstream does not support using lvm2 for the root filesystem because, as you
> discovered, the tools do not have complete support for it yet.

This is also nowhere documented: I've been using LVM2 as a root filesystem
for years without incident, so of course I thought it was meant to work.

(So much for backing up the whole system from snapshots, too...)

I must admit I can't see what's so special about the root filesystem.
>From the kernel's POV it's just another vfsmnt: you can even unmount it
if you have no open sessions and you have a rootfs still mounted under

Is it because the VG cfg backups are stored there?

> However people tried it and found it worked for them and so distributions
> started shipping this as an option despite incomplete support for the
> configuration in the upstream tools.  And so far nobody's considered it a
> high enough priority to get that support completed:-(

The tools work for me: even doing things like pvmoving root filesystems in
active use works fine. I'd vaguely guess that only snapshot support is

`In typical emacs fashion, it is both absurdly ornate and
 still not really what one wanted.' --- jdev

More information about the linux-lvm mailing list