[linux-lvm] Recovering PV and LG after fdisk or Repartition

Adam Tybor adam.tybor at gmail.com
Wed Jan 3 20:48:15 UTC 2007


I made a huge mistake last night.  I was repartitioning drives in my
system using fdisk.  I accidentally fdisk the wrong drive, rebooted,
and lost my lvm2.  In light of this error, I did a dd from the
original disk to another disk of the exact same geometry before I
started trying to recover the original.

Here is what I did to try and recover.
Disk 300GB 1 partition of type 8e /dev/sdc1
It had a single volume group on the pv which was /dev/sdc1

I tried recreating the PV using the archive file, that failed.  I
forced the creation of the PV on /dev/sdc1 with the uuid from the
archive file, that succeeded.

I then ran:
vgcfgrestore -n vg-storage -t -v -f /etc/lvm/backup/vg-storage vg-storage

This worked and restored my two logical volumes.  I then activated the
volumes running vgchange -ay.  Now I cannot mount the volumes.

The two volumes had reiserfs, mount will not mount them, a dmesg shows
this error.

ReiserFS: dm-6: warning: sh-2021: reiserfs_fill_super: can not find
reiserfs on dm-6

Running reiserfsck does nothing, it just returns immediately with no output.

I tried rebuilding the super block, the tree, everything.  It seems
like reiserfsck cannot find anything.

Is there anything else I can do, I really need this data?



More information about the linux-lvm mailing list