[linux-lvm] Some apparent success: recommendations?

Stuart D. Gathman stuart at bmsi.com
Mon Mar 5 21:03:37 UTC 2007

Based on what I've learned, I copied /etc/lvmconf/rootvg.conf to 
/etc/lvmtab.d/rootvg, overwriting the version copied from my system backup 
(which didn't include md3).   I then ran vgck, still no errors.  Then I 
ran lvremove -v /dev/rootvg/lvtest, which then succeeded!  Even better, 
the ondisk metadata for /dev/md3 is now "available".  The ondisk VG status 
is still "NOT available", but I believe this is normal based on checking
two other RHEL3 LVM1 systems.

What else should I check before rebooting?  Should I run vgscan ?  Does 
vgck compare ondisk metadata with kernel?  Is it safe to expand LVs now?  
Or should I reboot first?

	      Stuart D. Gathman <stuart at bmsi.com>
    Business Management Systems Inc.  Phone: 703 591-0911 Fax: 703 591-6154
"Confutatis maledictis, flammis acribus addictis" - background song for
a Microsoft sponsored "Where do you want to go from here?" commercial.

More information about the linux-lvm mailing list