Antw: Re: [linux-lvm] Can't get rid of INACTIVE read/write snapshot

Marcel Gsteiger Marcel.Gsteiger at
Mon Jul 21 08:13:09 UTC 2008

.sorry for the delay, I tried again to lvremove, find the strace enclosed.

After the output "flock(3, LOCK_EX

at the end, lvremove seems to go into an endless loop (100% CPU usage).

Then I tried the following:

kill -9 <pid of lvremove>
rm /var/lock/lvm/V_vg00

to remove /var/lock/lvm/V_vg00 "by hand" and tried again. Now the system does not go to 100% CPU usage anymore, but lvremove does not terminate. See my second lvremove2.strace.

As mentioned before, I simply wanted to get rid of a overflowed snapshot and clean up my volume group, as I should extend the LVM in question. How can I safely accomplish this in my situation?

Thanks for your help and best regards

>>> Mikulas Patocka <mpatocka at> 03.06.2008 21:15 >>>
> Hi all
> I'm using lvm2-2.01.08-2.1 on fc4, kernel 2.6.16-1 with linux-vserver 
> patches.
> A while ago, I mistakenly created a 39GB read-write snapshot of my 
> /vservers partition (which, btw, seemed to work). But after some time 
> this partition got to an overflow and since then I can't get rid of it 
> anymore. See the lvdisplay output below.
> lvchange -an or --refresh gives me a message "Can't change snapshot 
> logical volume "vservers_snapshot"".
> lvremove lets me wait, then "top" shows 100% IO-Wait but does not come 
> to an end (at least after an hour). I don't know how much patience I 
> would need, this box is rather fast otherwise (dual xeon 2.8GHz w/ SATA 
> drives).


It looks like an unknown bug in lvremove. Send a strace of lvremove while 
it waits for that long amount of time.


> Rebooting does not help anything.
> Is there a safe way to simply get rid of this snapshot? Any help would 
> much be appreciated.
> Regards
> --Marcel
> --- Logical volume ---
>  LV Name                /dev/vg00/lv00_vservers
>  VG Name                vg00
>  LV UUID                9oELP3-2l7d-gTML-2xg2-unTu-znP0-qVd3Mc
>  LV Write Access        read/write
>  LV snapshot status     source of
>                         /dev/vg00/vservers_snapshot [INACTIVE]
>  LV Status              available
>  # open                 1
>  LV Size                39,06 GB
>  Current LE             625
>  Segments               1
>  Allocation             contiguous
>  Read ahead sectors     0
>  Block device           253:9
>  --- Logical volume ---
>  LV Name                /dev/vg00/vservers_snapshot
>  VG Name                vg00
>  LV UUID                cQEj3z-V2jD-QOCl-3Yea-ETQZ-Egj9-2B7nd2
>  LV Write Access        read/write
>  LV snapshot status     INACTIVE destination for /dev/vg00/lv00_vservers
>  LV Status              available
>  # open                 0
>  LV Size                39,06 GB
>  Current LE             625
>  Segments               1
>  Snapshot chunk size    4,00 KB
>  Allocated to snapshot  100,00%
>  Allocation             inherit
>  Read ahead sectors     0
>  Block device           253:8
> _______________________________________________
> linux-lvm mailing list
> linux-lvm at 
> read the LVM HOW-TO at 

-------------- next part --------------
A non-text attachment was scrubbed...
Type: application/x-zip-compressed
Size: 12561 bytes
Desc: not available
URL: <>

More information about the linux-lvm mailing list