[linux-lvm] Re:HELP! (SOLVED)

David Baron d_baron at 012.net.il
Tue Oct 21 21:33:45 UTC 2008

On Monday 20 October 2008 19:15:12 linux-lvm-request at redhat.com wrote:
> Set up lvm, a breeze. NO lv root so should boot with a normal lilo.
> I was able to boot mounting the lvm volumes to the old failing disk.
> I cannot boot the new disk.
> Configuration
> 1 boot-ext3
> 2 root-ext3
> 3 swap
> 5 vfat
> 6 lvm volumes
> What type of lilo do I need for this. I ran it with
> boot /dev/hdc1
> root  /dev/hdc2
> All I get is the bootmagic text "preparing machine to start linux", then
> nothing.
> I am typing this in (gulp) window 98 (at least that still works--somewhat).
> The boot record of the old failing disk is messed so I canot use that
> knoppix 3.* will not allow me to chroot (its kernel too old)
> knoppix 5.01 will, but will not let me run lilo. The device mapper is too
> old for the (Sid) system.
> Please reply to my email as well as the list.
> Thank for any help

Figured this out! Udev is a catch-22. The /dev on a chroot'ed root is not a 
real /dev but a copy of whatever might have been there or even less than that. 
A search led to the answer: Use mount -bind to give that file-system a real 
/dev, then chroot and knoppix 5.01 will do that and lilo worked.

Other stuff did not work because of permissions to the copied /tmp. A quick 
google found /tmp permissions as the common thread in numerous problems. 777.

Up and running!

More information about the linux-lvm mailing list