[linux-lvm] Problems running my home-built LVM2

Stefan Monnier monnier at iro.umontreal.ca
Fri Feb 6 15:36:45 UTC 2009

I'm trying to use LVM2 on a small MIPS machine.  This machine uses
uClibc-0.9.29 with Linux- and has limited RAM and CPU power,
but does come with a 1TB drive which I'd rather manage with LVM.

I had no particular problems building the latest version of LVM2
for it.  And as far as I can tell, it's not fully broken,
but it's unusable: every run of `lvm' gives different results.
E.g. `lvm pvs' sometimes gives the expected output, sometimes lists
nothing at all, sometimes complains about missing volume groups,
sometimes "Incorrect metadata area header checksum" [as mentioned in an
earlier message on this list, incidentally].

I've taken a look at the compile log and didn't see any funny warning.
I tried to compile other versions of LVM (2.02.44, 2.02.43, 2.02.39),
but they all give the same result.

Then I installed Debian in a chroot, and Debian's 2.02.39 version of
`lvm' works just fine.

Does anyone have any idea what might be going on?

As a temporary workaround, I use "chroot /debian lvm" instead of "lvm",
but I really would like to get the "native" lvm working.


More information about the linux-lvm mailing list