[linux-lvm] Please help, [Incorrect metadata area header checksum]

me lvm at soulsweeper.org
Sat Jan 3 12:43:50 UTC 2009

Hello list,

i've got a (hopefully not) serious problem with my lvm installation.

I did some changes in my XEN-networking and wanted to reboot my server.
For this I did shutdown every DOM-U and tried to stop lvm with 'vgchange
-a n'. At this point lvm states 'Incorrect metadata area header
checksum', before this every worked fine. I tried to start lvm
immediately without success, a reboot didn't help either.
I searched the net (almost two days now) for a solution, without

1) It's not a filter-issue (lvm.conf), only loop-devices are scanned.
2) vgcfgrestore doesn't work either (tried only testrun)
3) pvcreate --uuid xxx --restorefile /etc/lvm/archive/xxx_00039.vg xxx
says, the uuid is already in use on /dev/loopX (correct device). I
didn't try the '--force'-option, I'm a coward at last :(

The last change (and reboot) was in november. I added two new drives and
growed the raid, rebooted the server and growed one lv. All without any
error. There's only one PV.

If you need any information (configs etc), I'll post everything ;)

--- snip ---

  Incorrect metadata area header checksum
  Incorrect metadata area header checksum
  WARNING: Volume Group alice is not consistent
  PV /dev/loop53   VG alice   lvm2 [6.37 TB / 408.57 GB free]
  Total: 1 [376.57 GB] / in use: 1 [376.57 GB] / in no VG: 0 [0   ]

Any help is appreciated!


More information about the linux-lvm mailing list