[linux-lvm] Problem to remove LVM snaphots

François Valenduc francois.valenduc at tvcablenet.be
Sun Apr 18 08:54:10 UTC 2010

Hello everybody,

I am using gentoo and I use LVM snapshots to make backups of my system.
Unfortunately, I always have a problem to remove these. LVM always
complains that it can't remove an open logical volume. However, the
snapshot is unmounted when I try to remove it. It seems it's only
possible to remove the snapshot if the corresponding volume is
deactivated. So, I am forced to boot on a live cd to remove the snapshot
of my root partition. Is this really normal ?
I already had that problem a long time ago and I thought it was solved
if a do a sync before removing the snapshot. It seems it's no more
sufficient. I am using LVM 2.02.56-r2, udev 149 and kernel

What is even more strange is that I can't even remove snapshot of
logical volumes which I have never mount. In fact, I do the following steps:
	lvcreate -L5G -n test gentoo
	lvcreate -n test1 -L1G -s /dev/gentoo/test
	lvremove gentoo/test1
And, I always get this error: Can't remove open logical volume "test1"

Am I forgetting something ? Until 2 month agos, this worked without any
error. Does anybody have an idea about this problem ?

Thanks in advance for your help,

François Valenduc

More information about the linux-lvm mailing list