[linux-lvm] Strange "waiting" message

Radu Rendec radu.rendec at mindbit.ro
Mon Nov 15 11:54:42 UTC 2010


I've run across a strange message that keeps being logged on a recently
upgraded system:

lvm[1081]: Another thread is handling an event. Waiting...

This starts appearing during system services startup (the kernel is
already done booting, init is started etc) and keeps popping up every 10

However, lvm seems to be working (I can list LVs, add new ones, perform
I/O on existing ones etc).

The system was originally installed with Centos 5 x86_32 and existing
VGs / LVs were created on that platform. Recently, the system has been
reinstalled with Fedora 14 x86_64, while keeping the lvm stuff

All google searches about this message led to cases where people tried
strange things with mirroring and multipath, but this is not the case.
It's just a simple VG with one PV on top of a linux raid5 device.

Is there any simple way to figure out what's holding the lock and what's
waiting on it?

Any (well, almost ;) information about that system can be provided if
needed - I tried to keep this message short and not to include (possibly
irrelevant) system logs and/or info.


Radu Rendec

More information about the linux-lvm mailing list