[linux-lvm] HDD failure - please help!

Patterson, James JPatte at lsuhsc.edu
Wed Sep 1 16:57:25 UTC 2010



I am more of a general user than a guru, so please be gentle...I'll do
my best to describe the issue here.


I have a system running FC11 with five HDDs, ~2 TB of space, all in a
logical volume. It was my presumption that the LVM system functioned
sort of like a raid system (I know you can run striped, for instance).
Everything has been running fine, up until last Monday - I noticed that
I couldn't write to my samba drive (on the machine in question) - it was
read only.


I thought: "Hmm". Whatever...I rebooted the system, but walked away
(busy) so didn't watch the reboot process. Came back and did use the
shared samba drive later - but later Tuesday, it went read-only again. 


OK, so I started looking around, and it appeared that I had a disk
failure from checking dmesg. Indeed, I could not access anything to
write - it was read only even for root  - because SElinux said
so...locked up. So...I rebooted again.


One of the five drives refused to come up - and made a rather ominous
clicking noise - would not initialize. The system would not boot at all.
Would get thru BIOS, pass the ATA card, and then stop. 


I pulled the drive out that was bad, dl'd and burned a boot CD-ROM,
booted off of that, and tried to do a restore.


I got an error message: "Error processing LVM.  There is inconsistent
LVM data on logical volume _____________.  You can reinitialize all
related PVs ___ which will erase the LVM metadata, or ignore which will
preserve the contents."


I tried ignore first, and it then stated that there were no partitions
to mount (or something - I didn't write this one down).

I rebooted, mounted read-only this time ( I didn't want to erase any
metadata) and tried re-initialize - got the same error message again.


I am at a loss as to what to do - I'm thinking that there must be a way
to recover the data on the remaining four drives. Surely this LVM system
is not going to cause me to lose the data on all five drives because one
of them failed?


I would greatly appreciate any help you could give me - I've search
quite a bit and can't seem to fine much in relation to this. It seems
like it would be something that had been addressed...somewhere.


Kind regards,





-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/linux-lvm/attachments/20100901/e16757c3/attachment.htm>

More information about the linux-lvm mailing list