[linux-lvm] Important diretories are missing after adding space.

For Miscelenious formisc at gmail.com
Sat Sep 4 13:29:15 UTC 2010

I added a second parttion to vg, extended lv and fs, mounted ir back. Checked -alm directories were in place. Proceeded with creation a few large files * also worked fine. Switched the machiine off and went to bed.
Next day booted to discover that few , but the most important, dies are missing. 

Please advise - I'm extremely upset. Since the back is outdated.
Here is a log from history I could retrive and some additional information.
I run Centos 5.4 rpm based. (2.6.18-164.15.1.el5.centos.plus) with lvm2 ( rpm 2.6.18-164.15.1.el5.centos.plus). I followed the [url]http://tldp.org/HOWTO/LVM-HOWTO/extendlv.html[/url] and 
here is the list of what i have (now):

cat /etc/fstab 
/dev/VG_SYS/LogVol00    /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
/dev/VG_SYS/LogVol01    swap                    swap    defaults        0 0
/dev/VG_Storage00/LG_VG_Storage00_00    /u01/app/       ext3    defaults        0 0
#/dev/mapper/VG_Storage01-LV_VG_STORAGE01 /mnt/storage  ext3    defaults        0 0
/dev/mapper/VG_Storage-LV_00    /mnt/storage    ext3    defaults        0 0

[root at server ~]# lvs
  LV                 VG           Attr   LSize   Origin Snap%  Move Log Copy%  Convert
  LogVol00           VG_SYS       -wi-ao 148.07G                                      
  LogVol01           VG_SYS       -wi-ao 896.00M                                      
  LV_00              VG_Storage   -wi-a- 931.33G                                      
  LG_VG_Storage00_00 VG_Storage00 -wi-ao 149.05G                                      
  LV_Backup          VG_backup    -wi-ao 232.87G                                      
[root at server ~]# vgs
  VG           #PV #LV #SN Attr   VSize   VFree
  VG_SYS         1   2   0 wz--n- 148.95G    0 
  VG_Storage     2   1   0 wz--n- 931.33G    0 
  VG_Storage00   2   1   0 wz--l- 149.05G    0 
  VG_backup      3   1   0 wz--n- 232.87G    0 
[root at server ~]# pvs
  PV         VG           Fmt  Attr PSize   PFree  
  /dev/hdc1  VG_Storage00 lvm2 a-    74.53G      0 
  /dev/hdc2  VG_backup    lvm2 a-    74.52G      0 
  /dev/hdd1  VG_Storage00 lvm2 a-    74.53G      0 
  /dev/hdd2  VG_backup    lvm2 a-    74.52G      0 
  /dev/hdd3  VG_backup    lvm2 a-    83.83G      0 
  /dev/sda2  VG_SYS       lvm2 a-   148.95G      0 
  /dev/sdb1  VG_Storage   lvm2 a-   465.67G      0 
  /dev/sdb5  VG_Storage   lvm2 a-   465.67G      0 
  /dev/sdb6               lvm2 --   465.93G 465.93G

now here is what i did.
i took the sdb5 and added to VG_STORAGE, extended lvs and extended the FS. Mounted and uuuupps. half of the directories are gone. 
here is the history of commands. All run w/o errors. Well, at least obvious errors that would have caught my eye.
umount /mnt/storage
vgextend /dev/mapper/VG_Storage /dev/sdb5
lvextend -l+100%VG /dev/VG_Storage00/LG_VG_Storage00_00
lvextend -l+100%FREE /dev/mapper/VG_Storage-LV_00
resize2fs /dev/mapper/VG_Storage-LV_00
e2fsck -f /dev/mapper/VG_Storage-LV_00
resize2fs /dev/mapper/VG_Storage-LV_00
df -h /mnt/storage/
Filesystem            Size  Used Avail Use% Mounted on
                      932G  488G  407G  55% /mnt/storage
du -hs /mnt/storage/
487G    /mnt/storage/

now, i think i mounted and checked the space.
i ran a couples of commands that created a few big files in the one the directories. Everything went just fine. I never checked if all old directories exist.

Today booted - and all directories/files i created after extension of the fs are in place. Some old dirs are there too. But some (~50%) are missing. Obviously, those are the ones i do care about the most..
Please help....
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/linux-lvm/attachments/20100904/8c998056/attachment.htm>

More information about the linux-lvm mailing list