[linux-lvm] LVM label lost / system does not boot

Ger Apeldoorn g.apeldoorn at fundeon.nl
Mon Jun 6 13:21:11 UTC 2011

On 06/05/2011 02:47 PM, Andreas Schild wrote:
> Hi
> The first part might sound like I am in the wrong group, but bear with 
> me...
> (I probably am, but I googled up and down RAID and LVM lists and I am 
> still  stuck):
> I have a software RAID 5 with 4 disks and LVM on top. I had one volume 
> group with two logical volumes (for root and data).
> I wanted to upgrade capacity and started by failing a drive, replacing 
> it with a bigger one and let the RAID resync. Worked fine for the 
> first disk. The second disk apparently worked (resynced, all looked 
> good), but after a reboot the system hung.
> After some back and forth with superblocks (on the devices, never on 
> the array) I was able to re-assemble the array clean.
> The system still does not reboot though: "Volume group "cmain" not found".
> I booted a live cd, assembled the array and did a pvck on the array 
> (/dev/md0):
> "Could not find LVM label on /dev/md0"
> pvdisplay /dev/md0 results in:
>   No physical volume label read from /dev/md0
>   Failed to read physical volume "/dev/md0"
> I do not have a backup of my /etc/ and therefore no details regarding 
> the configuration of the LVM setup (yes, I know...)
> All I have of the broken system is the /boot partition with its content
> Several questions arise:
> - Is it possible to "reconstitute" the LVM with what I have?
> - Is the RAID array really ok, or is it possibly corrupt to begin with 
> (and the reason no LVM labels are around)?
> - Should I try to reconstruct with pvcreate/vgcreate? (I shied away 
> from any *create commands to not make things worse.)
> - If all is lost, what did I do wrong and what would I need to backup 
> for a next time?
> Any ideas on how I could get the data back would greatly be 
> appreciated. I am in way over my head, so if somebody knowledgeable 
> tells me: "you lost, move on" would be bad, but at least would save me 
> some time...
> Thanks,
> Andreas
Have you tried 'vgscan -vvv' and 'pvscan -vvv' when started from a 
usb-stick or bootable dvd-rom? It might give you some more info. (post 
it here)


More information about the linux-lvm mailing list