[linux-lvm] lvremove is not deleting the file system

Guy Rouillier guy.rouillier at gmail.com
Mon Dec 30 00:58:04 UTC 2013

I'm using xen-create-image in an attempt to set up a new VM; host OS is 
Ubuntu Server 13.10, and I'm using LVM.  I failed in my first attempt 
due to my inexperience, so I changed some input parameters and I'm 
trying again.  The first attempt had successfully created the target LVM 
volumes for boot, root and swap, so I used lvremove to delete them.  All 
that went without error.

However, now when I try to run xen-create-image, I get the following 
error at the beginning when xen-create-image tries to create the target 

Creating btrfs filesystem on /dev/dell-vg/oraclelinux-root
/dev/dell-vg/oraclelinux-root appears to contain an existing filesystem 
Error: Use the -f option to force overwrite.
Running command 'mkfs.btrfs /dev/dell-vg/oraclelinux-root 2>&1' failed 
with exit code 256.

I've tried searching for this error but can't find anything helpful. 
I've rerun this a dozen times and get the same result each time 
(deleting the created volumes and rebooting between each attempt.)  I 
looked in the /dev tree, and I see the dm node (dm-4) disappears after I 
run lvremove.  But apparently, lvremove doesn't delete the filesystem. 
So when I recreate the same volume in the same order, the filesystem is 
still there from the previous attempt.

How do I fix this?  Thanks.

Guy Rouillier

This email is free from viruses and malware because avast! Antivirus protection is active.

More information about the linux-lvm mailing list