[linux-lvm] open count 1 blocking me from removing unused lv..

mixalis cossenas mixalis at evoip.gr
Wed Jan 30 08:43:46 UTC 2013

good day sirs,

i am using SLES sp1 on an IBM system z mainframe (s390 arch with DASD disks)
and i am facing the following problem...

i have one VG with 2 LVs ,the data from second lv was moved elsewere and i want
to remove the lv and free up the DASD disks BUT i have a problem...

when the data was moved ALL related daemons/programs writing/reading files on this lv
should be closed...but they werent.. :(

using lsof i found some apps accessing the old lv and they were killed,
also checking /proc/locks revealed programs that were closed...

tried to remove the lv by using lvremove but failed ,dmsetup -c info shows:

Name                Maj Min Stat Open Targ Event  UUID
system-home         253   0 L--w    1    1      0 LVM-QNFhmaviXPV05YkWno62o7zaEqaM3OMgcp1bhHr4HNLEaMskAgBUGkGAqeHwnXMV

open count is 1 and i cant find who/which keeps it open...

lsof  shows nothing....
cat /proc/locks | grep fd:00 shows nothing...

tried to remove it by using

lvremove system-home

dmsetup remove system-home

dmsetup --force remove system-home


any ideas (i am trying to avoid reboot) on how can i find what is keeping my lv open...?


Michael Cossenas.

More information about the linux-lvm mailing list