[linux-lvm] LVM snapshot with Clustered VG [SOLVED]

Andreas Pflug pgadmin at pse-consulting.de
Wed Mar 13 15:14:16 UTC 2013

Hi Vladislav,

I finally succeeded making all working as expected!

What I did:
- compile corosync 2.3.0 
- compile libqb 0.14.4 
- compile dlm_4.0.1 
- Compiled LVM 2.2.98 
    with your PREVIOUS patch ( 
https://www.redhat.com/archives/linux-lvm/2013-January/msg00006.html )

I made a 2-node test cluster, both accessing a test iscsi target, all 
daemons load fine.
Everything works as expected! Snapshotting is possible after -aey 
--force explicit exclusive locking, lvresize works as well.

Previously, I tried your latest patch. I had a plethiora of errors, 
starting with lvcreate failing:

#metadata/lv_manip.c:4137     Clearing start of logical volume "testvol2"
#device/dev-cache.c:599       /dev/san2/testvol2: stat failed: No such 
file or directory
#metadata/lv_manip.c:4140   /dev/san2/testvol2: not found: device not 
#metadata/lv_manip.c:4620   Aborting. Failed to wipe start of new LV.

I need to add -Z n to have it created. After that, most activations 
failed, with error code 5. I  went back to vanilla 2.2.98, all ok except 
exclusive locking, applied the initial locking patch and voila! All done.

Thanks for your support!

More information about the linux-lvm mailing list