[linux-lvm] vg disappeared after replacing disc in raid10

Björn Nadrowski bjrnfrdnnd at gmail.com
Mon Mar 25 21:50:58 UTC 2013

Well, I see I would have to remove the volume group first, at the very
Should I just issue

sudo vgremove vol0

followed by

sudo pvremove /dev/127

and followed by

sudo pvcreate --uuid WFo1On-anFb-2av8-DuRq-vKee-nJEt-ZLnu26 --restorefile
xt /dev/md127


But I would just be back in the middle of my problem description on
ubuntuforums, wouldn' t I?
Still no volume group, still no logical volumes...

On Mon, Mar 25, 2013 at 9:30 PM, Stuart D Gathman <stuart at bmsi.com> wrote:

> Long ago, Nostradamus foresaw that on 03/25/2013 04:46 PM, Björn
> Nadrowski would write:
> > Recreation of the volume group seemed  a good idea as I only had one
> volume group on the pv and therefore I did not see how this could have
> destroyed anything.
> > The (human-readable) data at the beginning of the device /dev/md127 is
> still there and does display the same information. Please see my posting
> Recreating the vg overwrites the human-readable data at the beginning of
> the device.  You claim that it is "still there" and is the "same
> information".  But this cannot be true because originally that
> information had your LV data, and now (apparently) it does not.  Do you
> see your LVs when looking at the vg metadata with an editor??   What do
> you mean by "displays the same information"?  Does lvs list your LVs?
> _______________________________________________
> linux-lvm mailing list
> linux-lvm at redhat.com
> https://www.redhat.com/mailman/listinfo/linux-lvm
> read the LVM HOW-TO at http://tldp.org/HOWTO/LVM-HOWTO/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/linux-lvm/attachments/20130325/8941287f/attachment.htm>

More information about the linux-lvm mailing list