[linux-lvm] Can't split VG which contains a thin pool

MegaBrutal megabrutal at gmail.com
Mon Mar 9 16:35:00 UTC 2015


I was trying to split a VG which has a thin pool in it. All data of
the thin pool was residing a PV which stays in the VG. The PV I
intended to split down only contained one LV which had no relation to
the thin pool whatsoever.

When I tried to use vgsplit, first it was telling me to deactivate the
thin pool, and when I did that, I got this:

root at thinkpad:~# vgsplit --verbose thinkvg adatavg /dev/sdb1
    Checking for new volume group "adatavg"
    Checking for volume group "thinkvg"
    Archiving volume group "thinkvg" metadata (seqno 143).
    Writing out updated volume groups
    Archiving volume group "adatavg" metadata (seqno 0).
  LV thinpool: segment 1 has inconsistent LV area 0
  Internal error: LV segments corrupted in thinpool.

After playing with it for a time with no success, I decided to
forcefully remove the PV from the VG, and just disconnected the drive.
On the origin machine, I could use "vgreduce --removemissing --force
thinkvg" to get rid of the disconnected PV without any problem. Then I
moved the disconnected PV to another system, which is now missing the
other PV. I also tried vgreduce to get rid of the other PV, but I got

root at blackpad:~# vgreduce --removemissing --force thinkvg
  Couldn't find device with uuid wlyc2h-ob6Y-zZae-SIo1-JhCn-aKwG-eq2fn2.
  Removing partial LV thinpool.
  Cannot activate thinkvgthinpool_tmeta: pool incomplete.
  Failed to update pool thinkvg/thinpool.

It seems LVM can't really handle to split or reduce VGs which has thin pools.

Any suggestions what should I do now to remove the missing PV on the other host?

  LVM version:     2.02.111(2) (2014-09-01)
  Library version: 1.02.90 (2014-09-01)
  Driver version:  4.29.0


More information about the linux-lvm mailing list