[linux-lvm] thin_check called with wrong path during "vgchange -ay"

Chris Friesen chris.friesen at windriver.com
Thu Nov 26 16:35:16 UTC 2015


I'm hoping this is a known issue.  I'm trying to use thin provisioning with 
openstack cinder.

If I run "vgchange -ay cinder-volumes" manually, it complains:

controller-0:/home/wrsroot# vgchange -ay cinder-volumes
   Check of thin pool cinder-volumes/cinder-volumes-pool failed (status:1). 
Manual repair required (thin_dump --repair 

If I run thin_check on /dev/mapper/cinder-volumes-cinder-volumes-pool_tmeta it 
complains that the file doesn't exist:

controller-0:/home/wrsroot# thin_check 
Couldn't stat dev path

The actual file name is /dev/mapper/cinder--volumes-cinder--volumes--pool_tmeta 
(note the double-hyphens) and if I run thin_check on that then it seems happy:

controller-0:/home/wrsroot# thin_check 
examining superblock
examining devices tree
examining mapping tree
checking space map counts

Does anyone know why thin_check is being called with the wrong filename?

For what it's worth, here's my lvm version:
controller-0:/home/wrsroot# lvm version
   LVM version:     2.02.95(2) (2012-03-06)
   Library version: 1.02.74 (2012-03-06)
   Driver version:  4.24.0


More information about the linux-lvm mailing list