[linux-lvm] lvconvert -m 0 /dev/varlin/distfiles /dev/md0 => zero filled logical volume

Raimonds Cicans ray at apollo.lv
Wed Mar 16 21:36:18 UTC 2016


I am trying to move LVM setup from old RAID md0 to new RAID md1

I did "lvconvert -m 1 /dev/path/to/logical_volume /dev/md1" on bunch of 
logical volumes.
Everything went without problems.

Then I tried to remove md0 from one of logical volumes by running command:
lvconvert -m 0 /dev/varlin/distfiles /dev/md0

I tried to mount this logical volume, but failed.

Then I checked first  megabyte of logical volume it was zero filled.

Partial output of "lvs -o+devices":
   LV              VG     Attr       LSize   Pool Origin Data%  Meta% 
Move Log Cpy%Sync Convert Devices 

   backup          varlin -wi-ao---- 100,00g 

   backup          varlin -wi-ao---- 100,00g 

   data            varlin -wi-ao----  20,00g 

   distfiles       varlin -wi-a-----  20,00g 

   ftp             varlin rwi-aor---  10,00g 
         100,00           ftp_rimage_0(0),ftp_rimage_1(0) 

   ftpdown         varlin rwi-aor---  10,00g 
         100,00           ftpdown_rimage_0(0),ftpdown_rimage_1(0) 

lvm2: 2.02.116
kernel: 4.4.2


1) What I did wrong?
2) Is it possible to salvage /dev/varlin/distfiles or I must restore it 
from backups?
3) What I should do now to get system to safe state?

Best regards,
Raimonds Cicans

More information about the linux-lvm mailing list