[linux-lvm] Unable to find device with UUID XXX.

Brian McCullough bdmc at bdmcc-us.com
Wed May 18 14:56:50 UTC 2016

On Wed, May 18, 2016 at 03:19:27PM +0200, Marian Csontos wrote:
> On 05/18/2016 02:22 AM, Brian McCullough wrote:
> >I have an issue that I hope that the group can save me from.
> >
> >I ran pvmove for about half of the PVs on the drive that was failing,
> >sending them to the new drive.  All seemed to be well.
> >
> >THEN, the data cable on the old drive ( USB 3 ) was disturbed, and
> >pvmove stopped, complaining that it couldn't see the drive.  OK, I can
> >fix this.  I plugged the cable back in, but things didn't seem to be any
> >better.
> BTW, pvmove is not a data rescue tool. It does not keep persistent log and
> it is necessary to resume synchronization between drives from scratch on
> reboot.
> Use ddrescue to get data from disks with errors.

Thank you.  I have seen recommendations for ddrescue to other people for
"dead drive" situations.  Didn't think that I was there yet.

> >I stopped the system, and rebooted.
> >
> >I have rebooted several times, with not completely consistent results.
> >
> >A couple of times it stopped when it said that it was loading the MD
> >drivers.
> We need to know more to help.

Yes, I know.  That's why I asked, so that you could tell me what I need
to give you.

> Are you using  md raid? If so is not using mdadm to replce and synchronize
> the drive better?

No.  Not on this machine.  I have used LVM on several machines over the
years, with success.  This is the first time that I have tried some of
the "deeper" commands.

> What distribution, version of LVM and kernel?

On the main machine, or the Rescue CD?

> `lsblk` output would help us to see what's there.
> `blkid` output would help us to see other bits and pieces.
> Also `vgs`, `lvs -avo+devices`, `pvs` output, too, please.

OK, I will work on those.

> >When I seem to have got the system booted properly, I do a pvs and it
> >complains about missing UUIDs.
> My guess is some of the PVs (those on the old drive) were marked missing and
> would have to be readded to the VG using `vgextend --restoremissing` before
> you can continue.

OK. I will get the output from the commands above, before I try this.

> Another possibility is, is lvmetad enabled and running?

No, or at least not as far as I know.  I have never intentionally done

> -- Martian


More information about the linux-lvm mailing list