[linux-lvm] Sorry to ask here ...

Georges Giralt georges.giralt at free.fr
Thu Feb 23 19:25:26 UTC 2017

Hello !

I'm sorry to ask for help here, but I'm lost in the middle of nowhere ...

The context :

A PC hardware with an UEFI "BIOS" set to legacy boot only.

3 disks with 2 partitions each. The 3 first partitions are set in 
software mirror (md0) and used for /boot (Ext4) .The second 3 partitions 
are used as a software mirror and the resulting md1 is the sole PV of a 
vg0 group onto which 8 logical volumes are set. This is used to run 
Ubuntu 16.04.2 software (after many upgrades...).   *

This setup has worked for years and seen changes in disk sizes, main 
board, etc...

Lastly, I bet the cause is an upgrade of some packages, the machine 
refuses to boot. It drops onto initramfs shell because the vg0 volume 
group is not activated. Launching lvm and doing a vgchange -a y does the 
trick and the system boots fine afterwards.

I've searched everything I can (but maybe the setup was so rock solid I 
became lazy or unconscious) and tried to make again the initramfs with 
no luck.

So every leads or advice would be greatly appreciated. Please, refrain 
to hit me hard on the face. I'm already mourning....

Many thanks in advance for your help !

* : The 3 disks are here because at one time, long ago, I used mirroring 
in the LVM software. ... I switched to software raid and kept the 3 
disks as I had them into the box.

"If a man empties his purse into his head, no man can take it away from him.
An investment in knowledge always pays the best interest"

Benjamin Franklin.

More information about the linux-lvm mailing list