[linux-lvm] lvmcache and bare mdadm arrays

Eugene Vikhman ujin981 at gmail.com
Wed Jan 16 19:27:30 UTC 2019


I spent the last couple of days trying to set up a new server with 16 
sas drives for the main storage and 2 SSDs for caching it using lvmcache.

First I used mdadm to create raid10 on HDDs and raid1 on SSDs. Then I 
followed the steps from the lvmcache manpage and the lvcreate/lvconvert 
manpages to create the cache and the metadata LVs and convert them to a 
cache-pool. It went fine, "lvs -a" showed a normal cache-pool device. 
But the last step failed with an ambiguous error when I used lvconvert 
--type cache --cachepool vg/cache vg/slow. I tried playing with 
parameters and made sure that the error had nothing to do with them. For 
an unidentified reason ioctl failed saying it could not lock the device 

Today I tried setting up the raids with lvm itself and it all worked 
like a charm.

So my thought is maybe manpages should actually mention something about 
it and say "don't try setting up caching on a bare mdadm raid - it won't 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/linux-lvm/attachments/20190116/5b8444f9/attachment.htm>

More information about the linux-lvm mailing list