[linux-lvm] Regarding the configure error while updating the LVM2 package

KrishnaMurali Chennuboina krishchennu414 at gmail.com
Mon Aug 24 16:16:31 UTC 2020


After further investigating the error message, i found that the below line
in configure file is causing the issue.

for ac_header in assert.h ctype.h dirent.h errno.h fcntl.h float.h \
  getopt.h inttypes.h langinfo.h libaio.h libgen.h limits.h locale.h
paths.h \
  signal.h stdarg.h stddef.h stdio.h stdlib.h string.h sys/file.h \
  sys/ioctl.h syslog.h sys/mman.h sys/param.h sys/resource.h sys/stat.h \
  sys/time.h sys/types.h sys/utsname.h sys/wait.h time.h \

While processing the above for loop the error message is getting observed
for libaio.h file.


On Mon, 24 Aug 2020 at 14:56, KrishnaMurali Chennuboina <
krishchennu414 at gmail.com> wrote:

> Hi,
> While updating the LVM2 package to lvm2-2_02_180, configure is failing
> with biling out error.
> Error Message Observed:
> checking for langinfo.h... yes
> checking libaio.h usability... no
> checking libaio.h presence... no
> checking for libaio.h... no
> configure: error: bailing out
> Snippet of the build script where configure is used:
> pkg_unpack
> ##
> # HACK: sbindir needs to be defined to ensure the systemd unit files don't
> get a
> # ${exec_prefix} prefix in executables' paths.
> ##
> CFLAGS="-g" ./configure --build=none --host=$TOOL_TRIPLET --prefix=/usr \
>        --libdir="/usr/$LIB_NAME" --enable-udev_rules --with-lvm1=none \
>        --enable-lvmetad --sbindir=/usr/bin \
>        ac_cv_func_malloc_0_nonnull=yes \
>        ac_cv_func_realloc_0_nonnull=yes
> Tried without passing any arguments to configure but still getting the
> same error message. Could you please suggest if the mentioned version is
> having dependency with any package??
> BR,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/linux-lvm/attachments/20200824/92528a1a/attachment.htm>

More information about the linux-lvm mailing list