[linux-lvm] Have tested dm-raid/lv mirroring with block guard on one leg but not the other, it fails to mirror the disk

Roger Heflin rogerheflin at gmail.com
Fri Nov 19 16:12:37 UTC 2021

I have tested dm-raid/lv mirroring and block guard on one leg but not
on the other and it initially seems to copy/mirror the device and then
random lv's start dropping the new block guard leg and set the refresh
attribute on the lv.   About this time we also start getting severe
filesystem corruption.  All that is being done is mirror the boot disk
to a SAN(block guard) lun and then split off that lun, and there is
breakage in the 10-30 minute window that takes.

I have tried on 2 vendor kernels and I have tried with fedora 35
(5.14.10-300) and all fail with similar overall results but slightly
different error messages in dmesg.

The redhat clone 7.9 kernel said this:  "tag#0 Add. Sense: Logical
block guard check failed", none of the other kernels had that good of
a message.   Fedora 35 got a DID_TRANSPORT_DISRUPTED and an io error
messages against a sector.    The other vendor kernel got basic IO
errors similar to what you get if you had a bad sector.

Any idea if it can be made to work?  Or made to refuse and error in lvm?

I have the commands used and /etc/lvm/archive/* entries for the device
and dmesg from the fedora kernel since it is almost a current
kernel.org kernel.   On  the vendor kernels we tried echo 0 to the
read_verify integrity entries on multipath and the underlying devices
and lvm seemed re-enable read_verify on the devices it built above the
devices it was disabled on when it was setting up/doing the mirroring,
we did not try that on the fedora kernel.


More information about the linux-lvm mailing list