No subject

Sat Mar 5 19:55:20 UTC 2022

me. So I installed the 2.6 kernel from rawhide on a test box and updated

Then I ran 

lvm vgscan -P --mknodes
lvm vgchange -P -a y
lvm lvchange -P -a y /dev/scsivg/disk2 (also for other LVs)

lvm lvdisplay -P scsivg then shows, in part,

  Partial mode. Incomplete volume groups will be activated read-only.
  1 PV(s) found for VG scsivg: expected 2
  Logical volume (swap) contains an incomplete mapping table.
  --- Logical volume ---
  LV Name                /dev/scsivg/disk2
  VG Name                scsivg
  LV UUID                000000-0000-0000-0000-0000-0000-000000
  LV Write Access        read/write
  LV Status              available
  # open                 0
  LV Size                4.50 GB
  Current LE             1152
  Segments               257
  Allocation             next free
  Read ahead sectors     10000
  Block device           254:0

Which implies that I should be able to do something with this LV. But

dd if=/dev/scsivg/disk2 of=/dev/null bs=1k count=1024
0+0 records in
0+0 records out

Does anyone have any suggestions of things I could try? 


(who's just worked out the hard way that having a VG span two disks is
not always a good idea)

More information about the linux-lvm mailing list